WordPress To Discontinue Support for PHP & MySQL 4

WordPress To Discontinue Support for PHP & MySQL 4

WordPress.org will discontinue its support of PHP 4 and MySQL 4 from version 3.2. WordPress 3.2 is due in the first half of 2011. However, WordPress 3.1 is still unreleased, due in late 2010.

From v3.2 on, self-hosted WordPress installs will require PHP 5.2. WordPress says that currently, only 11% of WordPress installs are running on servers using earlier versions than 5.2 of PHP, and only 6% currently run on MySQL 4 (after WP 3.1, minimum MySQL requirement will be version 5.0.15).

In a blog post about this, WordPress says:

Many [WordPress installs currently on PHP 4] are on hosts who support PHP 5.2 — users merely need to change a setting in their hosting control panel to activate it. We believe that percentage will only go down over the rest of the year as hosting providers realize that to support the newest versions of WordPress…they’re going to have to pull the trigger.

If you are not sure about the hosting settings, don’t worry. WordPress has created a plugin, Health Check plugin will tell you if you’re ready for WordPress 3.2. In a future release it will provide all sorts of useful information about your server and your WordPress install.

WordPress.org summaries as follows:

In summary: WordPress 3.1, due in late 2010, will be the last version of WordPress to support PHP 4 and MySQL 4. WordPress 3.2, due in the first half of 2011, will require PHP 5.2 or higher, and MySQL 5.0.15 or higher. Install the Health Check plugin to see if you’re ready!

By | On Monday, July 26th, 2010 | Under News | 3 Comments »


Contact our experts, most of the time we assist our readers free of charge.

Those who found this page were searching for:

  • google plus share link
  • wp и mysql 4
  • php discontinue
  • what wordpress version runs on mysql 4?
  • change the wordpress minimum mysql
  • wordpress conditional tags#sclient=psy
  • php discontinue support
  • mysql requirements wordpress
  • what versions of wordpress will run on mysql 4.0
  • My server still uses older version of PHP. Need to upgrade to PHP 5.2. But I don’t have any idea how I can do so. 🙁

    • There is nothing much for you to do. You should contact your hosting company to upgrade the software.

  • I have been facing this problem in my Thesis theme. But I didn’t have any idea about what is the source of this err. WordPress 3.0 was creating this problem??? huh!

    Thanks. Things should be fixed now…….I’m gonna to fix it.

Previous post:

Next post: